Skip to main content

Wallets

Wallets must support v1.0 and v2.0 in parallel. Our WalletConnect URIs are versioned and you can route the URI that was either scanned from a QR Code or redirected from a Deep Link, following the schema described in the EIP-1328.

When your wallet receives a v2.0 URI you must route it to the correct SDK.

Below we will list the SDK you must integrate for v2.0 protocol for each platform:

  1. iOS
  2. Android
  3. React Native
  4. Browser-based
  5. Unity
  6. Flutter

iOS

If you were using our WalletConnectSwift SDK (or any other community SDK), you must integrate the Web3Wallet SDK for Swift, for which you can find docs here.

Android

If you were using our WalletConnectKotlin SDK (or any other community SDK), you must integrate the Web3Wallet SDK for Kotlin, for which you can find docs here.

React Native

If you were using our WalletConnectClient SDK (or any other community SDK), you must integrate the Web3Wallet SDK for Javascript which you can find docs here and check out the RN Examples here.

Browser-based

If you were using our WalletConnectClient SDK (or any other community SDK), you must integrate the Web3Wallet SDK for Javascript which you can find docs here and check out the Web Examples here.

Unity

If you were using our WalletConnectSharp SDK (or any other community SDK), you must integrate the Sign Client for Unity which you can find docs here.

Flutter

If you were using OrangeWallet's WalletConnectDart SDK (or any other community SDK), you must integrate the Sign Client for Flutter which you can find docs here.